import Foundation
let pattern = #"(.)(.*?)*?\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
abbcabb
abca
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<2>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)