const regex = /((?s).*EventCode=4688*.)((?si).*(%%1936|%%1938TokenElevationTypeDefault|TokenElevationTypeLimited))
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?s).*EventCode=4688*.)((?si).*(%%1936|%%1938TokenElevationTypeDefault|TokenElevationTypeLimited))
', 'gm')
const str = `A new process has been created.
Creator Subject:
Security ID: SYSTEM
Account Name: RFSH\$
Account Domain: LAB
Logon ID: 0x3E7
EventCode=4688
Target Subject:
Security ID: LAB\\rsmith
Account Name: rsmith
Account Domain: LAB
Logon ID: 0x2C9D82
Process Information:
New Process ID: 0x2e0e4
New Process Name: C:\\Windows\\System32\\RuntimeBroker.exe
Token Elevation Type: %%1936
Mandatory Label: Mandatory Label\\Medium Mandatory Level
Creator Process ID: 0x268
Creator Process Name: C:\\Windows\\System32\\svchost.exe
Process Command Line:
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}