re = /^source\.(.+)$/m
str = 'source.organizations
source.departments
source.employees'
subst = 'EXTERNAL_\\U$1\\E'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result