re = /^\/scan\/anything\/se=([\w-.]+)\/se=((?:[\w-.]+)(?=\.html)|[\w-.]+)/m
str = '/scan/anything/se=hello-world/se=word.html
/scan/anything/se=hello-world.html/se=word.html
/scan/anything/se=hello-world/se=1.5/
/scan/anything/se=hello-world/se=1.5
/scan/anything/se=temp-2.5/se=1.5.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end