#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<={)(\d+)(?=:)"
Local $sString = "{"aclList": {0: {"sequence": {1: {"counterData": "some data""
Local $sSubst = ""\1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)