import re
regex = re.compile(r"(?<={)(\d+)(?=:)", flags=re.MULTILINE)
test_str = "{\"aclList\": {0: {\"sequence\": {1: {\"counterData\": \"some data\""
subst = "\"\\1\""
result = regex.sub(subst, test_str)
if result:
print(result)