import Foundation
let pattern = #"(?<={)(\d+)(?=:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"aclList": {0: {"sequence": {1: {"counterData": "some data""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""\1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)