$re = '/^(.+) > проверить, что элемент коллекции \"(.+)\" коллекции под номером (\d+) находится в состоянии (доступен|не доступен)(?: для редактирования|)$/m';
$str = 'То Проблемы_ОбновлениеПолей > проверить, что элемент коллекции "Поле Статус" коллекции под номером 2 находится в состоянии не доступен для редактирования';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);