# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Diagnostic-Code:\K.*(?:\R(?!Diagnostic-Code:).*)*"
test_str = ("Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does\n"
" not exist. Please try 550-5.1.1 double-checking the recipient's email\n"
" address for typos or 550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1\n"
" https://support.google.com/mail/?p=NoSuchUser 63si4621095ybi.465 - gsmtp\n\n"
"Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does\n"
" not exist. Please try 550-5.1.1 double-checking the recipient's email\n"
" address for typos or 550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1\n"
" https://support.google.com/mail/?p=NoSuchUser 63si4621095ybi.465 - gsmtp")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.