#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?isU)(<div class="([^"]+)">.+<div class="child-same-class">)"
Local $sString = "<div class="parent-first-class">" & @CRLF & _
" <div class="child-same-class">" & @CRLF & _
"" & @CRLF & _
"<div class="parent-second-class">" & @CRLF & _
" <div class="child-same-class">" & @CRLF & _
"" & @CRLF & _
"<div class="parent-third-class">" & @CRLF & _
" <div class="child-same-class">"
Local $sSubst = "$1\n\t<xf:if is="'$2' == 'parent-second-class'>...</xf:if>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)