use strict;
my $str = '<div class="parent-first-class">
<div class="child-same-class">
<div class="parent-second-class">
<div class="child-same-class">
<div class="parent-third-class">
<div class="child-same-class">';
my $regex = qr#(<div class="([^"]+)">.+<div class="child-same-class">)#isp;
my $subst = '$1\\n\\t<xf:if is="\'$2\' == \'parent-second-class\'>...</xf:if>';
my $result = $str =~ s#$regex#$subst#rg;
print "The result of the substitution is' $result\n";