package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?isU)(<div class="([^"]+)">.+<div class="child-same-class">)`)
var str = `<div class="parent-first-class">
<div class="child-same-class">
<div class="parent-second-class">
<div class="child-same-class">
<div class="parent-third-class">
<div class="child-same-class">`
var substitution = "$1\n\t<xf:if is="\$someVariable == '$2'">...</xf:if>"
fmt.Println(re.ReplaceAllString(str, substitution))
}