const regex = /^(.*?)\s*(\d+)\.(\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\s*(\\d+)\\.(\\d+)$', 'gm')
const str = `Hebrews 11.6
2 Chronicles 10.16
Romans 13.13
2 Kings 5.10
3 John 1.5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}