re = /style='((.|\n)*?)'/m
str = '<a style=\'width: 68px;text-align:center\'> < /a>
<a style=\'width: 68px;text-align:center;
padding:0cm 3.5pt 0cm 3.5pt;height:90.0pt\'> < /a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end