#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+ ?(?:(?:year|month|week|day|hour|min(?:ute)?|sec(?:ond)?)s?|[dhMmswy]) ?)+$"
Local $sString = "1y 5M 2w 3d 5h 50m 50s" & @CRLF & _
"1 year 5M 2 weeks 3d 5 hours 50 min 50 sec" & @CRLF & _
"5 weeks 2 hours" & @CRLF & _
"50s 50 minutes " & @CRLF & _
"9m9m9m9m9m9m9m9m9m9m9m9m9m9m9m9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")