import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d+ ?(?:(?:year|month|week|day|hour|min(?:ute)?|sec(?:ond)?)s?|[dhMmswy]) ?)+$";
final String string = "1y 5M 2w 3d 5h 50m 50s\n"
+ "1 year 5M 2 weeks 3d 5 hours 50 min 50 sec\n"
+ "5 weeks 2 hours\n"
+ "50s 50 minutes \n"
+ "9m9m9m9m9m9m9m9m9m9m9m9m9m9m9m9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}