$re = '/^(?:\d+ ?(?:(?:year|month|week|day|hour|min(?:ute)?|sec(?:ond)?)s?|[dhMmswy]) ?)+$/m';
$str = '1y 5M 2w 3d 5h 50m 50s
1 year 5M 2 weeks 3d 5 hours 50 min 50 sec
5 weeks 2 hours
50s 50 minutes
9m9m9m9m9m9m9m9m9m9m9m9m9m9m9m9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);