re = /MyFunction\(((?:[^()]++|\((?1)\))*)\)/m
str = 'MyFunction(23)
MyFunction(\'Sekret\')
MyFunction( 23, \'Sekret\', Date() )
MyFunction( Encrypt(\'Sekret\'), Date() )
logger.info("MyFunction( Encrypt(\'Sekret\'), Date() )")
MyFunction(as(()((das)))()(das(((das))))))
MyFunction( Encrypt(\'Sekret\'), Bla(Date()) )
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end