import Foundation
let pattern = #"r'\d+(?<![.,])[,|.]\d{2}(?![.,]\d)'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" ['1,000.45', '100.45', '7.89 ', '9769.71.046491.7', '123.45', '123', '1.234', '1,2', ' 10.00','12.09.21','210.00', '25.00', '238,50','4,34,34']"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)