$re = '/(?:BUY|SELL|LIMIT|STOP)(?:.*?)([A-Z]{6,})|([A-Z(GOLD)]{6,})(?:.*?)[\s*@#](?:BUY|SELL)|(GOLD)/m';
$str = 'XAUUSD BUY LIMIT@ 1803
XAUUSD SELL @1800
GOLD SELL
XAUUSD BUY@ 1811.3-1810
XAUUSD BUY NOW 1811.2
XAUUSD BUY 1811.3
XAUUSD BUY @ 1811.3
BUY LIMIT @XAUUSD@ 1811.
XAUUSD@BUY 1811.
XAUUSD@ BUY 1811.
XAUUSD @BUY 1811.
BUY LIMIT XAUUSD @1811.3
SELL LIMIT XAUUSD
U//scvxcxSELL XAUUSD
UxxczcSELL GOLD
xauusd buy@321321.23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);