package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{0,5}\s\-\s\d{0,2}\/\d{0,2}\/\d{4}$`)
var str = `25000 - 10/10/2021`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}