use strict;
my $str = ' \'[[\\"jewelry_designer\\"]\\n,[\\"watch_store\\"]\\n,[\\"jewelry_appraiser\\"]\\n,[\\"leather_goods_store\\"]\\n]\\n,null,\\"DpIJr_dR-DNu5kcR9RGmRprcnGU\\",null,null,null,[null]\'';
my $regex = qr/\\\"([^\"]{27})\\\"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}