#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2}))\.){3}(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2})))"
Local $sString = "1.1.1.1" & @CRLF & _
"254.2.2.2." & @CRLF & _
"255.1.1.255" & @CRLF & _
"256.1.1.256" & @CRLF & _
"012.111.111.111" & @CRLF & _
"12.12.12.12a" & @CRLF & _
"1q.1.1.1" & @CRLF & _
"1.1q.1.1" & @CRLF & _
"1.1.1q.1" & @CRLF & _
"1.1.1.1q" & @CRLF & _
"abcde254.2.2.2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")