use strict;
my $str = '1.1.1.1
254.2.2.2.
255.1.1.255
256.1.1.256
012.111.111.111
12.12.12.12a
1q.1.1.1
1.1q.1.1
1.1.1q.1
1.1.1.1q
abcde254.2.2.2';
my $regex = qr/(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2}))\.){3}(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2})))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}