$re = '/(?=(?=(?\'a\'[\s\S]*))(?\'b\'eat_(?:apple|pear|orange)_(?=\k\'a\'\z)|(?<=(?=x^|(?&b))[\s\S])))today|yesterday/m';
$str = 'eat_pear_today
yesterday';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);