# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)$/$1 DR/gm;t' <<< "03/01/2022,7−ELEVEN − TTSH LEV SINGAPORE SG,,SGD 1.10
03/01/2022,7−ELEVEN − TTSH LEV SINGAPORE SG,,SGD 2.00
03/01/2022,HEAVENLYWANG@HWMW SINGAPORE SG,,SGD 10.60
03/01/2022,DON DON DONKI SINGAPORE SG,,SGD 11.60
03/01/2022,LIFELINE CORPORATIO SINGAPORE SG,,SGD 106.00
04/01/2022,ESSO−CHEERS BY FP SINGAPORE SG,,SGD 2.50
04/01/2022,MCDONALD'S (QSC) SINGAPORE SG,,SGD 7.10
04/01/2022,SHELL PAYA LEBAR MA SINGAPORE SG,,SGD 17.35
03/01/2022,PAYMENT − THANK YOU 8,978.47CR
04/01/2022,SINGPOST − SAM KIOS SINGAPORE SG,,SGD 2.40
04/01/2022,Artisan Boulangerie Singapore SG,,SGD 9.94
05/01/2022,W S GO & ASSOCIATES SINGAPORE SG,,SGD 374.50
06/01/2022,ECCELLENTE MARINA SINGAPORE SG,,SGD 1.90
06/01/2022,COLD STORAGE−GREAT SINGAPORE SG,,SGD 16.10
06/01/2022,STARBUCKS@GREAT WLD SINGAPORE SG,,SGD 18.00
06/01/2022,STARBUCKS@GREAT WLD SINGAPORE SG,,SGD 18.00
06/01/2022,HIRAKI SINGAPORE SG,,SGD 30.48
06/01/2022,SINGAPORE NATIONAL SINGAPORE SG,,SGD 154.08
07/01/2022,KRAFTWICH @ PLSQ SINGAPORE SG,,SGD 20.30
07/01/2022,KIM CHOO HOLDINGS P SINGAPORE SG,,SGD 33.00
08/01/2022,STARBUCKS@WIKIE EDG SINGAPORE SG,,SGD 18.00
10/01/2022,ECCELLENTE MARINA SINGAPORE SG,,SGD 1.90
10/01/2022,MCDONALD'S (PSA) SINGAPORE SG,,SGD 17.80
11/01/2022,BRAWN AND BRAINS SINGAPORE SG,,SGD 31.90
11/01/2022,12 Jan A POKE THEORY−TRIPL SINGAPORE SG,,SGD 16.50"