# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(DTSTART|DTEND);[^:]+:([0-9]{8})T000[01]00/${1};VALUE=DATE:${2}/;t' <<< "DTSTART;TZID=Australia/Sydney:20230206T000000
"