using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(DTSTART|DTEND);[^:]+:([0-9]{8})T000[01]00";
string substitution = @"${1};VALUE=DATE:${2}";
string input = @"DTSTART;TZID=Australia/Sydney:20230206T000000
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}