import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(DTSTART|DTEND);[^:]+:([0-9]{8})T000[01]00";
final String string = "DTSTART;TZID=Australia/Sydney:20230206T000000\n";
final String subst = "${1};VALUE=DATE:${2}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}