re = /^(DTSTART|DTEND);[^:]+:([0-9]{8})T000[01]00/
str = 'DTSTART;TZID=Australia/Sydney:20230206T000000
'
subst = '${1};VALUE=DATE:${2}'
result = str.sub(re, subst)
# Print the result of the substitution
puts result