// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(DTSTART|DTEND);[^:]+:([0-9]{8})T000[01]00").unwrap();
let string = "DTSTART;TZID=Australia/Sydney:20230206T000000
";
let substitution = "${1};VALUE=DATE:${2}";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}