import Foundation
let pattern = #"^(DTSTART|DTEND);[^:]+:([0-9]{8})T000[01]00"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
DTSTART;TZID=Australia/Sydney:20230206T000000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1};VALUE=DATE:${2}"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}