#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*\/)*([^\/\r\n]+?|)(?=(?:\.[^\/\r\n.]*)?$)"
Local $sString = "filename.ext" & @CRLF & _
"filename." & @CRLF & _
"/filename" & @CRLF & _
"filename.ext" & @CRLF & _
"filename" & @CRLF & _
".filename" & @CRLF & _
"/path/.filename" & @CRLF & _
"filename.part1.ext" & @CRLF & _
"/path_a/path.b/" & @CRLF & _
"/path_a/path.b/filename"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")