re = /^(?:.*\/)*([^\/\r\n]+?|)(?=(?:\.[^\/\r\n.]*)?$)/m
str = 'filename.ext
filename.
/filename
filename.ext
filename
.filename
/path/.filename
filename.part1.ext
/path_a/path.b/
/path_a/path.b/filename'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end