import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*name[%=]([^&\\n]+)";
final String string = "http://bunnytalks.com/goingOn?name=Bunny&phone=2340\n"
+ "http://bunnytalks.com/goingOn?name=Bunny\n"
+ "http://bunnytalks.com/goingOn?name=Talks/whatson%goingOn%name%Bunny\n"
+ "http://bunnytalks.com/goingOn?name=Talks/whatson%goingOn%name%Bunny&phone=2340";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}