$re = '/\s+\(.+\)$/m';
$str = '제주특별자치도 제주시 첨단로 242 (영평동)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);