#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[2017\/(?:(?!\[\d{4}\/\d{1,2}\/\d)[\s\S])*?ID:00000015fd6c"
Local $sString = "[2017/4/16 2:28:29AM] (I) Radio mode changed to " & @CRLF & _
"SYSAXRADIO_E_STATE_PAGER_RX_SYNC on 170.9 MHz" & @CRLF & _
"" & @CRLF & _
"[2017/4/16 2:28:37AM] Tock = 1718" & @CRLF & _
"(I) IDTAG TAG : -90dBm : ID:00000015fd6c" & @CRLF & _
"(I) ***************" & @CRLF & _
"(I) ID TAG DETECTED 00000015FD6C" & @CRLF & _
"(I) ***************"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")