package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1?[\s-]?\(?(\d{3})\)?[\s-]?\d{3}[\s-]?\d{4}`)
var str = `(123)456-7890
123-456-7890
1 407 555 2497
123 456 7890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}