$re = '/"(\d+)"/';
$str = 'טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
על כל פנים יש פה מספרים מוקפים כמו "45678" ואפילו כמה כאלה "46546456456" אבל יש כאלה שלא!
כל הזכויות שמורות לתחומים.קום, 2018
';
$subst = "#$1#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;