#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\#\#\ (\d(\.\d)?(\.\d)?)"
Local $sString = "# Changelog" & @CRLF & _
"" & @CRLF & _
"## 1.2.3"
Local $sSubst = "## [$1](StorybookURL/$1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)