using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\#\#\ (\d(\.\d)?(\.\d)?)";
string substitution = @"## [$1](StorybookURL/$1)";
string input = @"# Changelog
## 1.2.3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}