import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:```(?:[^`](?!\\n\\n))+?```|`(?:[^`](?!\\n\\n))+?`)";
final String string = "Here we are going to be looking for `single-line inline code` and ```Code```\n\n\n"
+ "This `is code\n"
+ "test`\n\n"
+ "This `is not code\n\n"
+ "test`\n\n\n"
+ "```This is code\n"
+ "| variable | required |\n"
+ "|:-----------|:--------:|\n"
+ "| email | yes |\n"
+ "| first_name | yes |\n"
+ "| last_name | yes |\n"
+ "| website | no |\n"
+ "```\n\n\n"
+ "```This is not code\n"
+ "| variable | required |\n"
+ "|:-----------|:--------:|\n"
+ "| email | yes |\n\n"
+ "| first_name | yes |\n"
+ "| last_name | yes |\n"
+ "| website | no |\n"
+ "```\n\n\n"
+ "```Code\n"
+ "| variable | required |\n"
+ "|:-----------|:--------:|\n"
+ "| first_name | no |\n"
+ "| last_name | no |\n"
+ "| website | no |\n"
+ "```\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}