const regex = /(?:```(?:[^`](?!\n\n))+?```|`(?:[^`](?!\n\n))+?`)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:```(?:[^`](?!\\n\\n))+?```|`(?:[^`](?!\\n\\n))+?`)', 'gm')
const str = `Here we are going to be looking for \`single-line inline code\` and \`\`\`Code\`\`\`
This \`is code
test\`
This \`is not code
test\`
\`\`\`This is code
| variable | required |
|:-----------|:--------:|
| email | yes |
| first_name | yes |
| last_name | yes |
| website | no |
\`\`\`
\`\`\`This is not code
| variable | required |
|:-----------|:--------:|
| email | yes |
| first_name | yes |
| last_name | yes |
| website | no |
\`\`\`
\`\`\`Code
| variable | required |
|:-----------|:--------:|
| first_name | no |
| last_name | no |
| website | no |
\`\`\`
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}