use strict;
my $str = 'Here we are going to be looking for `single-line inline code` and ```Code```
This `is code
test`
This `is not code
test`
```This is code
| variable | required |
|:-----------|:--------:|
| email | yes |
| first_name | yes |
| last_name | yes |
| website | no |
```
```This is not code
| variable | required |
|:-----------|:--------:|
| email | yes |
| first_name | yes |
| last_name | yes |
| website | no |
```
```Code
| variable | required |
|:-----------|:--------:|
| first_name | no |
| last_name | no |
| website | no |
```
';
my $regex = qr/(?:```(?:[^`](?!\n\n))+?```|`(?:[^`](?!\n\n))+?`)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}