import re
regex = re.compile(r"(?:```(?:[^`](?!\n\n))+?```|`(?:[^`](?!\n\n))+?`)", flags=re.MULTILINE)
test_str = ("Here we are going to be looking for `single-line inline code` and ```Code```\n\n\n"
"This `is code\n"
"test`\n\n"
"This `is not code\n\n"
"test`\n\n\n"
"```This is code\n"
"| variable | required |\n"
"|:-----------|:--------:|\n"
"| email | yes |\n"
"| first_name | yes |\n"
"| last_name | yes |\n"
"| website | no |\n"
"```\n\n\n"
"```This is not code\n"
"| variable | required |\n"
"|:-----------|:--------:|\n"
"| email | yes |\n\n"
"| first_name | yes |\n"
"| last_name | yes |\n"
"| website | no |\n"
"```\n\n\n"
"```Code\n"
"| variable | required |\n"
"|:-----------|:--------:|\n"
"| first_name | no |\n"
"| last_name | no |\n"
"| website | no |\n"
"```\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")