Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(\d{1})[-](\d{3})[-](\d{3})[-](\d{4})
"
gm
Input 1
1
New
2124567890 212-456-7890 (212)456-7890 (212)-456-7890 212.456.7890 212 456 7890 +12124567890 +12124567890 +1 212.456.7890 +212-456-7890 1-212-456-7890 1-21-345-7890
Substitution