import Foundation
let pattern = #"(.{2})(.{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2346
UNDEF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)