const regex = new RegExp('<td class="character">.*?(?:<a.*?>)?(.*?)(?:</a>)?.*?</td>', 'gms')
const str = `<td class="character">
<a href=""> John Doe </a>
</td>
<td class="character">
</td>
<td class="character">
John Doe
</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}