$re = '@<td class="character">.*?(?:<a.*?>)?(.*?)(?:</a>)?.*?</td>@ms';
$str = '<td class="character">
<a href=""> John Doe </a>
</td>
<td class="character">
</td>
<td class="character">
John Doe
</td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);