re = /^(?!^[\p{Z}]|.*[\p{Z}]$).*$/m
str = ' x
x 
xx
 xx
 char \\u2000 at start
char \\u2000 at end 
in middle char \\u2000'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end